The error message that is displayed is as follows.
Review the \logs\Monitor.log file for entries related to EasyLicenser configuration errors similar to:
02 déc. 2008 15:51:31 [main] ERROR - MonitorServerImpl.callStartOnServers:
caught RemoteException exception calling WorkflowServer
02 déc. 2008 15:51:31 [main] ERROR - MonitorServerImpl.callStartOnServers:
RemoteException exception java.rmi.ServerError: Error occurred in server
thread; nested exception is:
java.lang.ExceptionInInitializerError: License key check
failed (1): Invalid EasyLicenser configuration condition. Tampered system
clock
OR
09 Mar 2005 11:04:31 [main] INFO - MonitorServerImpl.callStartOnServers: starting service WorkflowServer
09 Mar 2005 11:04:34 [main] ERROR - MonitorServerImpl.callStartOnServers: caught RemoteException exception calling WorkflowServer
09 Mar 2005 11:04:34 [main] ERROR - MonitorServerImpl.callStartOnServers: RemoteException exception java.rmi.ServerError: Error occurred in server thread; nested exception is:
java.lang.ExceptionInInitializerError: License key check failed (1): Invalid EasyLicenser configuration condition. Corrupt hidden file
09 Mar 2005 11:04:34 [main] INFO - MonitorServerImpl.callStartOnServers: starting service mailagent
Cause
If the DocuShare Servers system time is set to the future and then back to the present time during testing of a Workflow application this error can occur.
Each time workflow starts, it generates an .ezlm20jk file in the home directory of the user who started the DocuShare server (or the user logged in).
The error occurs when the .ezlm20jk file already exists and is one that is not related to workflow (might be created by another program that also uses .ezlm20jk).
Solution
Note: This solution requires that you stop DocuShare and you must be an administrator to perform this solution.
Note: Example below has the steps for Windows; the same solution applies to Linux and Solaris however the steps will be different.
From the DocuShare Server,
1. Stop the DocuShare service by using either the stop_docushare command line utility or stop DocuShare if you are running it as a service by using the Services Administrative Tool.
2. Click Start | highlight Search | select For Files or Folders. The Search Results window will be displayed.
3. In the All or part of the file name: field type .ez* the search should find a file or several files called .ezlm20jk
NOTE: This file is usually found in the following location C:/Documents and Settings//.ez*. on windows and on UNIX it is ~/.ez*.
4. Rename the file(s) .ezlm20jk file to something else. (such as oldezlm20jk)
Note: Make sure the date modified on the directory that the .ezlm20jk file was located in is set to the current time and date after you rename the .ezlm20jk file. To view the date modified, open Windows Explorer and right click the folder that contained the .ezlm20jk file | select Properties or View menu | select Details verify date modified.
5. Log off the DocuShare server
6. Log back on to the DocuShare Server
7. Start the DocuShare service by using either the start_docushare command line utility or stop DocuShare if you are running it as a service by using the Services Administrative Tool.
Note: A new .ezlm20jk file will be created automatically when workflow starts.
Note: If you are still getting the error message and/or the .ezlm20jk file is not being created you can try running DocuShare via the command line. Open a command prompt window | change into the Xerox\Docushare\bin directory | type start_docushare command. If DocuShare starts successfully this way then there may be a permissions issue with the account specified to start DocuShare (by default this is the system account)
Solution Updated: January 27th, 2012
Solution ID: 279