Note: This solution applies to DocuShare 6.01 and 6.5.x
Issue:
If you try to select a Saved Routing Slip from the Use Route Slip drop down menu in the Edit Properties of a Collection, the Saved (private) Routing Slips are partially displayed or not displayed in the drop down menu.
Cause:
This issue occurs because the one or several routing templates (Saved Routing Slip) do not have an owner. When a template does not have an owner assigned it causes a nullpointer exception error and the code to exit out of the loop that does the listing during the fetching of the templates and because the error occurs during the fetching of saved routing templates sometimes the dropdown would contain partial listing of templates.
Solution:
This issue will be fixed in a patch for DocuShare, until the patch is available the following workaround has been provided.
Workaround:
Note: You must be a DocuShare Administrator to perform this solution.
To resolve the issue:
1. Log into DocuShare as admin
2. Click Admin Home | Services and Components | Workflow | Workflow Manager | List Workflows. The List Workflows page displays.
3. Place a checkmark in the Template checkbox.
Note: There should not be a checkmark in the Active, Completed, Unactivated, Aborted and Has Aborted Task checkboxes.
4. Click the Refresh button
5. Delete any templates that do not have an owner listed under the Owner column.
To delete a template:
a. Select the checkbox next to the template(s) that do not have an owner listed in the Owner column
b. Click the Delete button
Note: You must check all of the templates listed, if multiple pages of templates are listed then you will need to view each of the pages one by one and delete any templates that do not
Solution Published: October 15th, 2009
AR 0022239